Firefox 3* – instalacja niekompatybilnych rozszerzeń

11/07/2009 – 11:53

Niedawno wyszła nowa wersja Firefoksa – 3.5. Niestety, jak zresztą za każdym razem w przypadku nowej wersji, duża część używanych przeze mnie rozszerzeń, nie jest kompatybilna z Fx 3.5. No i jest oczywiście kilka sposobów na obejście tego problemu. Jeden z nich, dotyczy modyfikacji samego rozszerzenia i pozmieniania paru numerków w odpowiednich plikach. Jest to jednak proces mozolny, dlatego wielce mi nie odpowiadał.

Natknąłem się za to na świetny dodatek, który – teoretycznie – jest skierowany dla testerów nowych wersji Fx, ale sam zacząłem z niego korzystać, ze względu na jedną z możliwości dodatku – siłowa instalacja niekompatybilnych rozszerzeń, za pomocą jednego kliknięcia – czyli bez mozolnej edycji plików.

Zachęcam do zapoznania się z dodatkiem Nightly Tester Tools.

BTW, najnowsza wersja Iceweasel (3.5) jest dostępna w repozytorium experimental. Uwaga! Jest ona dostarczana bez tłumaczenia, co oznacza, że np. polski język interfejsu, trzeba będzie zainstalować samodzielnie.

  1. komentarzy 8 dla “Firefox 3* – instalacja niekompatybilnych rozszerzeń”

  2. Czyli lepiej poczekać aż wejdzie do testowych repozytoriów ;D

    By RzeLeK on Lip 11, 2009

  3. Hehe, dlaczego? To, że paczka jest w experimental nie oznacza, że nie nadaje się do użytku. To wynika z wytycznych debiana – niektóre paczki muszę po prostu wpierw wejść do experimental, potem do sid, testing i w końcu stable.

    Iceweasel to tylko minimalna przeróbka Firefoksa 3, tak więc, bez obaw – jest jak najbardziej stabilna.

    By Kaka' on Lip 11, 2009

  4. W takim razie, żebym mógł ściągnąć go, to muszę dodać sobie repo experimental ?

    By RzeLeK on Lip 11, 2009

  5. Ups, z tego co widzę to paczka została właśnie usunięta z experimental :P

    By Kaka' on Lip 11, 2009

  6. A skąd wiesz, że zostały usunięte ? Jak to sprawdzasz ?

    I drugie pytanie to czy żeby zainstalować jakiś pakiet z innej wersji Debiana, niż mam zainstalowaną, to wystarczy dodać repo tej wersji do swoich ?

    By RzeLeK on Lip 11, 2009

  7. Sprawdzić możesz tutaj: http://www.debian.org/distrib/packages

    W kwestii drugiego pytania, to tak. Pamiętaj jednak, że nowsze wersje programów wymagają także nowszych wersji innych pakietów i w niektórych przypadkach, nawet jedno zaktualizowanie programu, do wersji np. z unstable bądź experimental, w przypadku kiedy posiadasz stable, może skutkować aktualizacją dziesiątek/setek pakietów. Musisz uważać, aby nie narobić sobie problemów z zależnościami, przez tego typu zagrania.

    By Kaka' on Lip 11, 2009

  8. Ok, dzieki :)

    By RzeLeK on Lip 11, 2009

  9. Paczka ponownie trafiła do experimental.

    By Kaka' on Lip 14, 2009

Napisz komentarz